Performance Issues Official Thread - PlanetSide Universe
PSU Social Facebook Twitter Twitter YouTube Steam TwitchTV
PlanetSide Universe
PSU: I love you, you love me - Vanu Theme Song
Home Forum Chat Wiki Social AGN PS2 Stats
Notices
Go Back   PlanetSide Universe > PlanetSide Discussions > PlanetSide 2 Discussion

Reply
Click here to go to the first VIP post in this thread.  
Thread Tools Search this Thread Display Modes
Old 2013-03-17, 04:46 PM   [Ignore Me] #1
Goku
Contributor
PSU Moderator
 
Goku's Avatar
 
Performance Issues Official Thread


I have been noticing a number of performance issue threads popping up due to the recent patches that have come out for the game. However I don't think these are really contributing towards getting the actual problem solved. Instead keep to this thread and avoid making other threads.

In order to help the developers get down and fix the issue please do the following:

1. Give your system specs (CPU, GPU, RAM, and so on)
2. Your performance prior to the game update causing you issues (Give setting/Resolution)
3. Your performance currently in game now with the recent updates (Give setting/Resolution)

Its worthwhile doing this even if you aren't experiencing issues, so the devs can see the kind system that aren't.

Doing this the developers that do read this forum can get better feedback on the issue. This is a lot better than just saying "my computer has bad FPS please fix it", which does nothing to help.

Last edited by Goku; 2013-03-17 at 04:47 PM.
Goku is offline  
Reply With Quote
Old 2013-03-17, 04:55 PM   [Ignore Me] #2
almalino
First Sergeant
 
almalino's Avatar
 
Re: Performance Issues Official Thread


No performance issues.

Intel i2500k 4.3 GHz
Radeon 5870 1GB
RAM 8GB
SSD 128GB
High settings

I feel game plays even faster now.

Last edited by almalino; 2013-03-17 at 04:58 PM.
almalino is offline  
Reply With Quote
Old 2013-03-17, 04:55 PM   [Ignore Me] #3
p0intman
Lieutenant Colonel
 
p0intman's Avatar
 
Misc Info
Re: Performance Issues Official Thread


NOT experiencing issues:
win7 64 bit
intel i5-3570 (4 cores at ~3.4ghz
8gb ram (pny manufactured)
dx11
nvidia geforce gtx 550 ti
high settings EXCEPT for lighting quality, which is at medium, running ps2 at a resolution of 1848/1116 in windowed mode on display running at roughly 1920/1200
2TB hdd storage with roughly two thirds still available.
__________________

Retired NC CR5, Cerberus Company.
Not currently playing PS2. Anyone with a similar name is not me. My only characters are listed in my stats profile here on PSU.

Last edited by p0intman; 2013-03-17 at 04:56 PM.
p0intman is offline  
Reply With Quote
Old 2013-03-17, 05:28 PM   [Ignore Me] #4
Goku
Contributor
PSU Moderator
 
Goku's Avatar
 
Re: Performance Issues Official Thread


Originally Posted by phungus View Post
Performance isn't an issue unless you are trying to play this game on a system that can't reasonably support the game's intended scope.

Hell if you are complaining about performance you're the reason why this game is actually unplayable with invisible god mode being the dominant feature on the battlefield due to render distance.
This isn't a thread about bad performance due to have a Intel P4 and 9800 XT trying to play the game. The recent game update crippled performance for people even with higher end rigs. Doesn't seem like its effecting everyone, but the intended purpose of this thread is to collect information that will be useful for the developers. A post like yours isn't contributing at all, so please avoid making such posts in this thread.
Goku is offline  
Reply With Quote
Old 2013-03-17, 05:31 PM   [Ignore Me] #5
Snydenthur
Master Sergeant
 
Re: Performance Issues Official Thread


Problems with fps and a lot of stuttering. Before gu4, I had 99% of the time over 30fps and it was much smoother. Now fps seems to drop under 30 even in smaller and medium fights. And after it drops under 40, I begin to see a lot of stuttering. Flying seems to stutter even more.

i3-2130, gtx 660, 8gb ddr3. Win 7 64bit.

Fps drops to around the same amount with any settings. Shadows and flora are always off though.
Snydenthur is offline  
Reply With Quote
Old 2013-03-17, 05:51 PM   [Ignore Me] #6
Red Ketchup
Private
 
Red Ketchup's Avatar
 
Re: Performance Issues Official Thread


i5 3570, HD7950, 8gb ram, 256gb Corsair M4 SSD, Windows 7 64 bits.

Lots of stuttering after about an hour since GU4. No problem whatsoever during the first hour. The stuttering is especially noticeable when flying an aircraft; looking at a major facility results in the worst stuttering.
All graphic settings are set to high.
Exiting the game and relaunching it fixes the problem (for an hour).

I also noticed that after an hour, when the stuttering appears, the game takes much longer to exit. As if it was unloading a lot of stuff in memory or something.

UPDATE: Played 4 and a half hours yesterday (March 23rd) without problems. The fix is working in my case.
__________________
Disclaimers:
1) I have never played Planetside 1.
2) English is not my first language.

Last edited by Red Ketchup; 2013-03-24 at 03:46 PM.
Red Ketchup is offline  
Reply With Quote
Old 2013-03-17, 05:53 PM   [Ignore Me] #7
SternLX
Sergeant
 
SternLX's Avatar
 
Re: Performance Issues Official Thread


No performance issues for me, just a bit of server lag here and there.

Windows 7 x64 - High Performance Power Plan
Click My CPU-Z Validation below for hardware.
__________________


SternLX is offline  
Reply With Quote
Old 2013-03-17, 05:56 PM   [Ignore Me] #8
seerss
Private
 
Re: Performance Issues Official Thread


AMD A6-3400M Overclocking 2.4GHZ
AMD HD6650M
2G+4G RAM
500GB HDD
128GB SSD
1366*768

home 40~50fps
battlefield low 30~40
battlefield high 20~30

today15!!!!,on the home 23!! wtf!!

Last edited by seerss; 2013-03-17 at 05:58 PM.
seerss is offline  
Reply With Quote
Old 2013-03-17, 05:59 PM   [Ignore Me] #9
CraigX
Private
 
Re: Performance Issues Official Thread


Patch increased performance a little bit especially on the ground in medium to large battles. My fps still drops from 60-70 in warpgates down to low 20s in medium to large battles. Additionally, there is humongous stuttering while flying even with light activity in an area.

Windows 7 64 Bit
Intel Core i5 3570K CPU @3.4 Ghz
8 GB Ram
Nvidia Geforce GT 640
Playing Medium settings with high effects @ 1280 x 768
75% Render with 1500 render distance.
GPU PhysX on

I don't know if this makes a difference or not but I'm playing using the steam client.

Last edited by CraigX; 2013-03-17 at 06:05 PM.
CraigX is offline  
Reply With Quote
Old 2013-03-17, 07:03 PM   [Ignore Me] #10
GreyFu
Private
 
Re: Performance Issues Official Thread


I'm running on 2 setups frequently

On my desktop its improved
i7 - 930 @4.5ghz
24 GB Ram
nVidia GTX 670 2GB
Running from a Ramdisk setup of 12gb
Ultra [email protected]

home Now - 70~100fps
Hot battle Now - 45~90FPS

On my laptop its gotten worse
i7 3630QM @3.5ghz
16GB
nVidia GTX 660M
Running from a mSata SSD
Ultra textures (plenty of memory)
Shadows off
Lighting low
Graphics Quality High
1080p

Home Now - 35~60FPS
Home Before - 45~70FPS

Hot battle now - 18~40FPS
Hot Battle before - 35~60FPS

It's a shame the GPU never seems to be a limit on the game (something we all already knew), I had the settings tweaked to a point of optimal quality with no performance hit to the 660m but as mentioned the desktop is running amazing so it's a bit of an odd one. Hope they get some things straightened out, really looking forward to bigger utilization's then steps back.

I like most am curious to know what rigs are being used to showcase the game out and about FNO etc. An answer I never expect to get but I have a dreadful feeling that the name of the processor begins with an X. :/

Last edited by GreyFu; 2013-03-17 at 07:13 PM.
GreyFu is offline  
Reply With Quote
Old 2013-03-17, 07:24 PM   [Ignore Me] #11
Hmr85
Lieutenant Colonel
 
Hmr85's Avatar
 
Re: Performance Issues Official Thread


I have two PC builds.

AMD FX-4100 OC to 4ghz
16GB Ram
EVGA GTX 580
Windows 7 64 bit.
resolution 1680x1050

I run the game on all High settings.

Prior to GU04 I was getting 70+ FPS in small skirmishes (Half a Platoon). 30 FPS in major fights.

So for me it was a huge performance hit that hopefully gets fixed here soon.
Come GU04 I was getting 40+FPS in small skirmishes (Half a Platoon). 18 FPS in major fights.

Second build.
Win 7 - x64
16 GB Ram
AMD FX - 8120
EVGA GTX 580 x2 SLI
resolution 1680x1050

Prior GU04 I was getting 120+ FPS in small skirmishes (Half a platoon) In Major fights I was getting 40ish+ FPS.

GU04 I was getting 80+ FPS in small skirmishes (Half a Platoon) In major fights I was getting 25+ FPS.

So all in all this new update took a big hit on both my systems.
__________________


Hmr85 is offline  
Reply With Quote
Old 2013-03-17, 08:35 PM   [Ignore Me] #12
camycamera
Major
 
camycamera's Avatar
 
Re: Performance Issues Official Thread


specs (yes, slightly the same version of the pc you reccomended for me, thnx for that btw )
i5 3570
ASUS GTX 650ti
8gb RAM
windows 7 64 bit (if this is of any help...)
resolution: 1280x1024

i run the game with all settings on high, always have.

prior to patch:

i would almost always get above 30 fps in all types of battles, never below. when there were a large amount of people around, obviously it was CPU bound, but when there was no-one or a group of people around, it was Gpu bound obviously.

after patch (and also obviously after this so called "hotfix" that claimed to fix the problem):

fine when just walking around in open spaces with a couple of people, about 30 fps (but i remember it would get something like 40 prior). i also realised that i would get about 20-28 frames in i think both tech plants and amp stations, no matter how many people there was on my screen, it boggled my mind, especially when prior it ran fine, especially in those areas. i also had found problems with large groups of people, like enemy/friendly tank zergs, etc (you get my point, lots of poeple), that prior, i wouldn't get any problems with, it ran fine, above 30. now, it drops to 20. i was stunned. furthermore, i have realised that i am almost ALWAYS CPU bound. i dont get it. at one stage there was nobody on my screen (and i think i was at a tech plant, if that is of any help), it was CPU bound. seriously, i think the only time it was GPU bound was when i was looking at the ground or the sky, and that has never happened before.

it kinda sucked that these performance issues occurred during the double xp weekend, because i would have had a much better experience than i would have (although i had a much better time than most multiplayer FPS's anyway).

but, i am used to low FPS anyway, because of mah old PC i have had for so many years... and i get better fps in PS2 now than my old pc anyway .

but still, FIX PLEX
__________________


Last edited by camycamera; 2013-03-17 at 11:04 PM.
camycamera is offline  
Reply With Quote
Old 2013-03-17, 09:50 PM   [Ignore Me] #13
Simo
Private
 
Re: Performance Issues Official Thread


i5 2500k
GTX 570
8gb RAM
Win 7 64bit
25mbs connection

Sporadic issues. Primarily lag/delay since GU4. Lots of getting taking hits well after the encounter ended, needing 3 or 4 attempts to get out of vehicles, getting a kill credit long after the fact, random xp values for repairs, etc.

But sometimes it seems to play fine.
Simo is offline  
Reply With Quote
Old 2013-03-17, 11:49 PM   [Ignore Me] #14
Pronam
Private
 
Pronam's Avatar
 
Re: Performance Issues Official Thread


AMD 8350 8core 4.0ghz
16gb 2133MHZ
AMD HD7870 2gb 1ghz
256 SSD
1080p
28mbs
100ms (EU->Waterson) {Yup as EU servers make no difference for me in lag}

Graphics/Terrain/Texture Quality High
All others on low
Shadows Off

Dramatic game setting changes do little, disabling shadows in the ini used to help a lot but not after GU4. I'm randomly changing it from ultra/high/medium. Low usually does more worse than good, which makes sense after their talk of cpu->gpu division.

These are semi-biased due to the current server lag but are still pretty accurate.
30~90 randomly in air but the high end never in any player to player situations.
40~50 in quiet situations (120 when facing the ground lol)
25~50 warpgate
20~35fps in platoon battle
15~30 platoons
7~20 platoonz (crazy big dramatic war scenes)

Before the update, which did bring a lot of new and old players to the game, I averaged between 25-50 all the time, which was perfectly fine for me. Though the lag is more an annoyance than the fps. I used multiple setups, cleaned ini's, reinstalled the game, used with/without steam. nope.avi.difference. Ironically I have had almost no crashes since gu4.
Pronam is offline  
Reply With Quote
Old 2013-03-18, 03:57 AM   [Ignore Me] #15
Pella
Captain
 
Pella's Avatar
 
Re: Performance Issues Official Thread


While there's no point in me posting my stats as SOE wont/cant replicate my setup.

Let it be known. That the problem exists. And its some form of Memory leak again which we experienced just after Launch.

If it was just me i wouldn't complain. I have to relog every 30mins for my FPS to get back to normal.

90% Of my outfit which is about 25 People, All wtih different set up's are experiencing exaclty the same problem. Where the FPS drop below -30fps and doesnt come back until you relog. And you can even look at the floor with noone around and it wont move above.

Some have said its something todo with Debris hanging in the air or the ground for a long period of time.

INDAR at prime time [MILLER] Is impossible to play on.
__________________

Last edited by Pella; 2013-03-18 at 04:02 AM.
Pella is offline  
Reply With Quote
Reply
  PlanetSide Universe > PlanetSide Discussions > PlanetSide 2 Discussion

Bookmarks

Wiki Activity Read More >
Discord

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:02 AM.

Content © 2002-2013, PlanetSide-Universe.com, All rights reserved.
PlanetSide and the SOE logo are registered trademarks of Sony Online Entertainment Inc. © 2004 Sony Online Entertainment Inc. All rights reserved.
All other trademarks or tradenames are properties of their respective owners.
Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.