Performance Issues Official Thread - Page 4 - PlanetSide Universe
PSU Social Facebook Twitter Twitter YouTube Steam TwitchTV
PlanetSide Universe
PSU: Look at all the cute Vanu!
Home Forum Chat Wiki Social AGN PS2 Stats
Notices
Go Back   PlanetSide Universe > PlanetSide Discussions > PlanetSide 2 Discussion

Reply
Click here to go to the first VIP post in this thread.  
Thread Tools Search this Thread Display Modes
Old 2013-03-28, 12:00 AM   [Ignore Me] #46
Sledgecrushr
Colonel
 
Re: Performance Issues Official Thread


So this is what I got right now, Im saving for an upgrade.
Core 2 quad @2.4 ghz
Radeon 5750 1 gig
4 gig ram
Win vista 32 bit
Running on ultra low

Just got done playing for three hours. I didnt get the flicker bug at all and my framerate hovered around 18 fps at a big crown fight. This is pretty outstanding results considering my computer was out of date three years ago.
Sledgecrushr is offline  
Reply With Quote
Old 2013-04-01, 10:32 PM   [Ignore Me] #47
Fimconte
Private
 
Fimconte's Avatar
 
Re: Performance Issues Official Thread


Originally Posted by dethred View Post
Obviously spending less money is better, but you will never ever get near the performance of two cards.

Honestly, games that aren't made by incompetent programmers generally see excellent benefits from SLI. The problem is that with the developer in this case, I'm afraid.
You can't offload most of the things that cause PS2 to be CPU bound onto the CPU.

And you can't really blame the Developers for the lack of Clock Speed increases over the last few years.

Multi-threading is great, but it's difficult to code for. Hopefully we'll see a steady increase in the future and maybe more offloading to other cores.
__________________


Fans glory to the Gladiators,
Gods glory to the Heroes.
Fimconte is offline  
Reply With Quote
Old 2013-04-01, 11:40 PM   [Ignore Me] #48
Palerion
Sergeant Major
 
Re: Performance Issues Official Thread


1. I'm running a 3570k processor with a GTX 660ti card. 8gb ram
2. Ran on all settings maxed (high, not ultra) 1080p at a constant 80+ out of battle, dropped to 50-60, occasionally in the 40s during extremely intensive battles.
3. Running all settings maxed 1080p at a constant 60fps out of battle, sometimes dipping into the 50s. In intense battles I run at 40-50 and occasionally dip even into the high 30s.
__________________
Palerion is offline  
Reply With Quote
Old 2013-04-02, 05:24 AM   [Ignore Me] #49
ringring
Contributor
General
 
Re: Performance Issues Official Thread


Experiencing issues when I'd say I wasn't (much) several weeks ago.

i7 2600k @ 3.4
8 Gb RAM
GTX650Ti 1Gb

I normally get 35-45 it can dip as low as 25 momentarily or as high as 60-70 but normal is 35-45.

My issue is that 35-45 feels worse than it did a couple of months ago. Although I get FPS numbers which felt good enough now everything feels so laggy.

In addition I get:
- repairs that don't work properly
- map lag
- information not appearing on the map or mini-map, specifically squad and - platoon mates are entirely missing.
- Claymores and mines no longer do damage (fairly recent one that)
- Claymores and mines deconstructing
__________________

Last edited by ringring; 2013-04-02 at 06:02 AM.
ringring is offline  
Reply With Quote
Old 2013-04-02, 08:55 AM   [Ignore Me] #50
Snydenthur
Master Sergeant
 
Re: Performance Issues Official Thread


Judging by a quick testing, changing a new cpu helped a lot. With i3-2130 I had about 30 minimum with biggest battles taking it down to about 25 occasionally. The problem with that i3 was that there was some sort of microstutter or something, that made even that 30fps feel a lot lower. Microstutter usually started around 60fps, when there were people near, but 60fps with less people was smooth.

Now I have i5-2500k. I'm running it stock, since I didn't upgrade my motherboard to a one that allows overclocking yet. There weren't any massive battles yet, but with enemy platoon detected fps seemed to be around 50 with a few dips below it. Microstutter was completely gone though and that was the main reason for this upgrade anyway (+ quad core is much better for other games too).

Edit. Oh yeah, I did change maxvoices from 30 to 96. Don't really know if that really helped me with i3, but at least now I don't lose the sound of my weapon when there are a lot of other sounds nearby.

Last edited by Snydenthur; 2013-04-02 at 08:58 AM.
Snydenthur is offline  
Reply With Quote
Old 2013-04-02, 09:05 AM   [Ignore Me] #51
Assist
Contributor
Major
 
Re: Performance Issues Official Thread


Originally Posted by Palerion View Post
1. I'm running a 3570k processor with a GTX 660ti card. 8gb ram
2. Ran on all settings maxed (high, not ultra) 1080p at a constant 80+ out of battle, dropped to 50-60, occasionally in the 40s during extremely intensive battles.
3. Running all settings maxed 1080p at a constant 60fps out of battle, sometimes dipping into the 50s. In intense battles I run at 40-50 and occasionally dip even into the high 30s.
Just an fyi, when I switched to running Ultra settings I gained FPS in large battles. I used the settings stickied in the tech forums here(2nd post by Ailos in that thread) and up'd most stuff to ultra while dropping some stuff to low, but I'm running a lot older processor than you and my performance was never that good to begin with. I run a GTX 680 though, which I think has allowed me to run some ultra settings without taking any impact on my FPS.
Specifically these settings didn't drop my FPS at all, and actually increased my FPS in large battles. Game looks quite a bit nicer than High as well, really notice it on the texture/graphics detail on the weapons.

OverallQuality=-1
LightingQuality=4
EffectsQuality=4
TerrainQuality=4
GraphicsQuality=4
TextureQuality=0
__________________
Assist is offline  
Reply With Quote
Old 2013-04-02, 09:41 AM   [Ignore Me] #52
Snydenthur
Master Sergeant
 
Re: Performance Issues Official Thread


Originally Posted by Assist View Post
Just an fyi, when I switched to running Ultra settings I gained FPS in large battles. I used the settings stickied in the tech forums here(2nd post by Ailos in that thread) and up'd most stuff to ultra while dropping some stuff to low, but I'm running a lot older processor than you and my performance was never that good to begin with. I run a GTX 680 though, which I think has allowed me to run some ultra settings without taking any impact on my FPS.
Specifically these settings didn't drop my FPS at all, and actually increased my FPS in large battles. Game looks quite a bit nicer than High as well, really notice it on the texture/graphics detail on the weapons.
A lot of people are saying this, but I don't really see a reason why this would up the minimum fps. Cpu does the same amount of work. It's true that if you're cpu bound, you can up the settings to make the game look better, but it should not have any effect on minimum fps. This is my understanding of it. I might be wrong or forgelight is different from other engines in that case.

I don't really like using ultra myself, since they make it harder to see enemies. Ultra for textures, medium for the graphics quality, high for model quality, everything else is low or off. I have tried ultra settings, but only thing I saw different was the max fps.
Snydenthur is offline  
Reply With Quote
Old 2013-04-02, 09:48 AM   [Ignore Me] #53
Hamma
PSU Admin
 
Hamma's Avatar
 
Re: Performance Issues Official Thread


That is strange that Ultra would INCREASE FPS
__________________

PlanetSide Universe - Administrator / Site Owner - Contact @ PSU
Hamma Time - Evil Ranting Admin - DragonWolves - Commanding Officer
Hamma is offline  
Reply With Quote
Old 2013-04-02, 10:29 AM   [Ignore Me] #54
wasdie
Second Lieutenant
 
wasdie's Avatar
 
Re: Performance Issues Official Thread


PhysX still destroys my performance with my 2x GTX 570s. I've tried everything too. Updating drivers, dedicating the 2nd GPU to physx. Nothing works.
__________________
wasdie is offline  
Reply With Quote
Old 2013-04-02, 10:37 AM   [Ignore Me] #55
wasdie
Second Lieutenant
 
wasdie's Avatar
 
Re: Performance Issues Official Thread


Originally Posted by Hamma View Post
That is strange that Ultra would INCREASE FPS
Not really. A steady load on a processor will always out perform inconsistent loads. Dropping your graphics down means the GPU isn't working as consistently hard thus it has times where there is a very light load on it and other times where it needs to be increased.

Even if you turn on the "prefer maximum performance" setting in your GPU's control panel doesn't mean this problem goes away.

If you have a modern GPU (2011+) then running high/ultra settings should run better for you. It seems that ultra even uses a bit different rendering algorithms that are more efficient on modern hardware, thus look better and run better compared to high/medium/low.

The problem with this game's performance is actually all CPU based. When I'm out alone looking over an empty terrain with ultra settings I can pull in over 100 fps. Even when there are some friendlies and vehicles around me to be rendered. If the VR area is empty of players I still get 80+ even when looking at all of the spawned vehicles and infantry while I'm causing explosions. The actual graphical renderer of this engine is really efficient and very well optimized. It literally all falls onto the CPU with this game and that's going to be tough for them.

CPU utilization cannot magically increase in a network-heavy game such as this. You cannot just thread up your network processing if you want to keep sync with the server. It becomes much more difficult. Things in the engine are threaded up but the vast majority of the processing comes from your CPU interpreting all of the data it gets from the server for player movement, vehicles, and ballistics. The more you feed through that pipe, the slow it's going to go.

They could have made more design decisions to decrease CPU load, but it would have made it even easier for hackers and would have ruined the game. For example they could have made every weapon in the game pure hitscan greatly reducing the amount of data that the server and clients need to track. However that would really ruin the game.
__________________
wasdie is offline  
Reply With Quote
Old 2013-04-02, 10:52 AM   [Ignore Me] #56
Snydenthur
Master Sergeant
 
Re: Performance Issues Official Thread


Originally Posted by wasdie View Post
Not really. A steady load on a processor will always out perform inconsistent loads. Dropping your graphics down means the GPU isn't working as consistently hard thus it has times where there is a very light load on it and other times where it needs to be increased
This doesn't have anything to do with minimum fps, which is the problem in the game. It's true that if you use ultra, you get a more stable fps. But your minimum fps will still be the same, since your cpu is limiting it.

Let's say that you'll get 30-250 fps with everything on low. Then you put on ultra settings. Your fps is now 30-60fps. Of course, you can limit fps on low settings to the same 30-60, so it's more of a personal thing. Do you want to have a simpler view or do you prefer graphics.

Last edited by Snydenthur; 2013-04-02 at 10:54 AM.
Snydenthur is offline  
Reply With Quote
Old 2013-04-02, 11:10 AM   [Ignore Me] #57
Palerion
Sergeant Major
 
Re: Performance Issues Official Thread


Originally Posted by Assist View Post
Just an fyi, when I switched to running Ultra settings I gained FPS in large battles. I used the settings stickied in the tech forums here(2nd post by Ailos in that thread) and up'd most stuff to ultra while dropping some stuff to low, but I'm running a lot older processor than you and my performance was never that good to begin with. I run a GTX 680 though, which I think has allowed me to run some ultra settings without taking any impact on my FPS.
Specifically these settings didn't drop my FPS at all, and actually increased my FPS in large battles. Game looks quite a bit nicer than High as well, really notice it on the texture/graphics detail on the weapons.

OverallQuality=-1
LightingQuality=4
EffectsQuality=4
TerrainQuality=4
GraphicsQuality=4
TextureQuality=0
Thanks, I'll give that a try. I had tried to use ultra settings previously, and noticed about a 10-20fps drop, but these settings look like they could work.

EDIT: Wow, thanks! Brought me back up to my previous 70-80 out-of-battle framerate.
__________________

Last edited by Palerion; 2013-04-02 at 11:21 AM.
Palerion is offline  
Reply With Quote
Old 2013-04-02, 11:19 AM   [Ignore Me] #58
Dragonskin
Major
 
Re: Performance Issues Official Thread


AMD Phenom X6 1055T 2.8ghz
8gb ram
AMD HD Radeon 7970 3gb


I get roughly 30-40 no matter what setting I use. Sometimes I get slightly higher on high going into the 40-50 range. I might try the adjustments to see if Ultra does anything.
__________________


Last edited by Dragonskin; 2013-04-02 at 11:26 AM.
Dragonskin is offline  
Reply With Quote
Old 2013-04-02, 11:34 AM   [Ignore Me] #59
wasdie
Second Lieutenant
 
wasdie's Avatar
 
Re: Performance Issues Official Thread


Originally Posted by Snydenthur View Post
This doesn't have anything to do with minimum fps, which is the problem in the game. It's true that if you use ultra, you get a more stable fps. But your minimum fps will still be the same, since your cpu is limiting it.

Let's say that you'll get 30-250 fps with everything on low. Then you put on ultra settings. Your fps is now 30-60fps. Of course, you can limit fps on low settings to the same 30-60, so it's more of a personal thing. Do you want to have a simpler view or do you prefer graphics.
That's exactly why I said the real bottleneck of this game is your CPU.
__________________
wasdie is offline  
Reply With Quote
Old 2013-04-02, 08:00 PM   [Ignore Me] #60
Palerion
Sergeant Major
 
Re: Performance Issues Official Thread


Yeah, on a second notice... I got into some bigger battles... Had a drop into the 20s. Afraid I'm going to have to go back to high settings
__________________
Palerion is offline  
Reply With Quote
Reply
  PlanetSide Universe > PlanetSide Discussions > PlanetSide 2 Discussion

Bookmarks

Discord

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:20 PM.

Content © 2002-2013, PlanetSide-Universe.com, All rights reserved.
PlanetSide and the SOE logo are registered trademarks of Sony Online Entertainment Inc. © 2004 Sony Online Entertainment Inc. All rights reserved.
All other trademarks or tradenames are properties of their respective owners.
Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.