FPS still terrible. - PlanetSide Universe
PSU Social Facebook Twitter Twitter YouTube Steam TwitchTV
PlanetSide Universe
PSU: I need 15cc's of love, STAT!
Home Forum Chat Wiki Social AGN PS2 Stats
Notices
Go Back   PlanetSide Universe > PlanetSide Discussions > PlanetSide 2 Discussion

Closed Thread
Click here to go to the first VIP post in this thread.  
Thread Tools Search this Thread Display Modes
Old 2013-03-15, 10:34 AM   [Ignore Me] #1
Assist
Contributor
Major
 
FPS still terrible.


So I tried last night for about 2 hours to fix my FPS. The best luck I had was attempting to use Ultra settings, which put me around 80 FPS at the warpgate but I was still tanking to below 25 in fights against just 'squads'. I managed to hit 9 FPS at an Amp Station, I almost felt like that was an accomplishment.
I don't know what the hotfix actually changed, but it didn't make it any better for me.
I've installed/reinstalled every driver I can think of and I attempted to use the GeForce Experience thinger but that just cranked up every setting possible. Really hope they put more of an effort into fixing the performance of the game. No point in having a gorgeous game if it's near unplayable with those settings.
__________________
Assist is offline  
Old 2013-03-15, 10:45 AM   [Ignore Me] #2
psijaka
Contributor
Major
 
psijaka's Avatar
 
Re: FPS still terrible.


I've not normally suffered many problems with FPS drop offs with previous patches, but several times it dropped to 20-23FPS last night, especially when there were a lot of vehicles around. Starts to make life difficult.
psijaka is offline  
Old 2013-03-15, 12:04 PM   [Ignore Me] #3
ThatGoatGuy
First Sergeant
 
Re: FPS still terrible.


FPS bombed with the latest GU. And with the hotfix, it was said to make stuff even worse.
ThatGoatGuy is offline  
Old 2013-03-15, 06:16 PM   [Ignore Me] #4
Snydenthur
Master Sergeant
 
Re: FPS still terrible.


Is everyone still having fps-problems? Seems like the hotfix fixed my fps. BUT. Now there is a lot of stuttering. Playing in a large battle, I have a very stable 28-30fps, but because of this new stuttering, it feels like 10-15 fps. That's what makes this game at the moment unplayable for me. Before gu4 and hotfix, I had the same around 30fps, but it wasn't as stable. But it was much smoother, so I could still aim and shoot people quite easily.

Flying is even worse. If I fly over a base that has some players, the stutter makes it totally impossible to aim and even the basic flying is hard.

This seems much worse on Indar. I had some playtime on Esamir today and while fps acted pretty much the same as on Indar, there wasn't much stutter.
Snydenthur is offline  
Old 2013-03-15, 07:44 PM   [Ignore Me] #5
EVILPIG
Contributor
Colonel
 
EVILPIG's Avatar
 
Re: FPS still terrible.


I have no FPS issues. However, I do have 32GB of RAM. Perhaps all in this thread should be posting their stats?
__________________
"That which does not kill us,
makes us stronger
" -Nietzsche

www.planetside-devildogs.com
EVILPIG is offline  
Old 2013-03-15, 08:06 PM   [Ignore Me] #6
camycamera
Major
 
camycamera's Avatar
 
Re: FPS still terrible.


it used to be fine, hell i even tried ultra + gpu physics for some time and my pc was running 30 fps on it....

then after a while i had turned all of that off for obvious reasons, and left it on high and i was getting below 30 fps in fights that were big in amp stations, but i NEVER used to get THAT low FPS EVER, espesially in an AMP station before the patch

specs

i5 3570
gtx 650ti
8gb ram
__________________

camycamera is offline  
Old 2013-03-15, 08:12 PM   [Ignore Me] #7
Pella
Captain
 
Pella's Avatar
 
Re: FPS still terrible.


Its a known issue.

Same happend just after launch when they messed with the render distance.

When i relog it works fine for 30mins. Then 30fps Maximum

I5 2500K @ 4.9Ghz
AIT 7970
16GB Ram
Windows 8
__________________
Pella is offline  
Old 2013-03-15, 08:38 PM   [Ignore Me] #8
Assist
Contributor
Major
 
Re: FPS still terrible.


Originally Posted by Pella View Post
Its a known issue.
World turmoil is a known issue too but sometimes they need to be reminded when it's not solved!

Higby posted that the hotfix deployed should fix some of the FPS issues that started with GU04. Just making sure it's known that it's not fixed for most of us still and I don't think it hurts to make sure they know it! Performance of the game is a major a reason quite a few people are not playing right now, more than enough to warrant a more thorough look at the issue.

i7 @ 3.8 ghz
GTX 680 2gb
12gb DDR3 1600
Windows 7 64
__________________

Last edited by Assist; 2013-03-15 at 08:41 PM.
Assist is offline  
Old 2013-03-15, 09:08 PM   [Ignore Me] #9
SGOniell
First Sergeant
 
Re: FPS still terrible.


No good for me, terrible FPS, and I use to run everything in High settings.

Windows 7 64 bit
nvidia Quadro 2000M 3.76 GB
Intel i7 @ 3.2 GHz
8 GB DDR2 1333 MHz
__________________
"Ever Heard of the chain of command? Its a chain I go get and beat you with 'till you understand who's in ruttin' command" -Jayne Cobb
"Out of ammo and full of bullets" -anonymous friend
SGOniell is offline  
Old 2013-03-15, 11:23 PM   [Ignore Me] #10
Riekopo
Sergeant
 
Riekopo's Avatar
 
Re: FPS still terrible.


Possibly memory leak issue. 32GB of RAM doesn't matter because the game is 32 bit and limited to using 2GB I think.
Riekopo is offline  
Old 2013-03-15, 11:31 PM   [Ignore Me] #11
Silent Thunder
Staff Sergeant
 
Silent Thunder's Avatar
 
Re: FPS still terrible.


No its 4GB. Planetside is large address aware.
Silent Thunder is offline  
Old 2013-03-16, 03:38 AM   [Ignore Me] #12
Sturmhardt
Contributor
Major
 
Sturmhardt's Avatar
 
Re: FPS still terrible.


FPS are still bad for me. 30 FPS in crowded areas with my i52500k @4,4Ghz
I mean wtf? I wonder how all the people with smaller CPUs feel...
__________________
Sturmhardt is offline  
Old 2013-03-16, 05:59 AM   [Ignore Me] #13
Emperor Newt
Second Lieutenant
 
Re: FPS still terrible.


FPS are the same for me. Only issue I have is that my weapons stop doing damage when too many people are around.

*edit*
dafuq! Only played a little yesterday. Now after I logged in my fps are cut in half, if not more. In a warpgate with a few people I used to have around 50+ fps, now I am down to 20 to 15. In small to medium engagements I used to be around 30 fps. Now I am down to 15. Large engagements? No chance. Below 10 fps now.
Also loading stuttering increased by a lot.

That in strong companionship with the no damage/desync bug... Best double xp weekend ever.

Last edited by Emperor Newt; 2013-03-16 at 08:27 AM.
Emperor Newt is offline  
Old 2013-03-16, 10:59 AM   [Ignore Me] #14
bjorntju1
Captain
 
bjorntju1's Avatar
 
Re: FPS still terrible.


I5 3570k
GTX 580 SLI
16 GB RAM
Windows 8 64 bit
Game is installed on an Samsung 830 SSD

Got around 17 FPS 2 days ago in a big fight in a biolab. I played yesterday and it felt a little bit better, but still shit.
__________________
bjorntju1 is offline  
Old 2013-03-16, 11:13 AM   [Ignore Me] #15
Ghoest9
Lieutenant Colonel
 
Ghoest9's Avatar
 
Re: FPS still terrible.


No one is talking about their settings.

I use more or less medium settings and have good FPS.

2500k i5
8 gigs RAM
Win 7
HD7850
__________________
Wherever you went - Here you are.
Ghoest9 is offline  
Closed Thread
  PlanetSide Universe > PlanetSide Discussions > PlanetSide 2 Discussion

Bookmarks

Discord

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:10 PM.

Content © 2002-2013, PlanetSide-Universe.com, All rights reserved.
PlanetSide and the SOE logo are registered trademarks of Sony Online Entertainment Inc. © 2004 Sony Online Entertainment Inc. All rights reserved.
All other trademarks or tradenames are properties of their respective owners.
Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.